[Résolu] Gérer les interfaces réseau

[Résolu] Gérer les interfaces réseau

Postby jjm » 11 Aug 2016, 01:12

Cet ordi a deux cartes Ethernet :

--intégrée à la carte mère : via-rhine
--sur pci : Realtek 8139 C

Contrairement à Mageia et openSUSE, je n'ai rien trouvé pour activer ou non-activer au démarrage ces interfaces.
Chacune communique avec le routeur via un adaptateur CPL.
Comme dans ROSA elles sont activées toutes les deux, quand j'utilise l'ordi "à moi tout seul je suis deux", ce qui est génant pour les autres utilisateurs.
Ce que je souhaite c'est que la carte intégrée ne soit pas activée (je la ménage), et que seule la carte sur PCI le soit (je peux la remplacer).
Donc, dans ROSA, actuellement j'ai deux solutions que je souhaite ne pas utiliser :
--débrancher le câble
--désactiver par l'icône réseau dans Plasma, ou manuellement dans un terminal root dans MATE
Ces deux solutions me déplaisent : je souhaite que cela soit automatique, afin de l'oublier.
S'il faut installer un utilitaire, je suis partant.
Merci pour votre aide.
Last edited by jjm on 15 Aug 2016, 23:11, edited 3 times in total.
Seuls ceux qui sont assez fous pour penser qu'ils peuvent changer le monde y parviennent.
Henri Dunant, fondateur de la Croix Rouge
jjm
 
Posts: 132
Joined: 08 May 2013, 00:07

Re: Gérer les interfaces réseau

Postby sylvainsjc » 11 Aug 2016, 08:18

Salut,
Dans Plasma comme dans MATE tu peux accéder aux connexion réseau et désactiver celle que tu ne souhaites pas utiliser. non ?
User avatar
sylvainsjc
 
Posts: 1273
Joined: 28 Jun 2012, 19:39

Re: Gérer les interfaces réseau

Postby jjm » 11 Aug 2016, 23:28

Non, je n'ai pas trouvé. C'est pour cela que j'ai initié cette discussion.
Dans Plasma, il y a bien une icône pour gérer les interfaces réseau, mais cela ne semble pas être concerné lors du démarrage.
Exemple, pour la carte intégrée enp0s18, configuration générale, l'option "Se connecter à ce réseau quand dispopnible" est désactivée, et pourtant la connexion est active puisque je l'utilise présentement.
J'ai cherché ailleurs dans le système, et n'ai rien trouvé concernant les interfaces réseau lors du démarrage du système.
L'icône de Plasama, me semble t-il n'est active qu'après connexion au système.
Mon avis : ROSA diverge (de plus en plus) de Mandriva, par exemple pour des raisons de maintenance des modules.
C'est une très bonne distribution, "avec très peu ou pas de gros défaults de qualité", mais certains outils présents dans Mandriva et Mageia sont absents.
Peut-être ai-je mal cherché. Dans ce cas, je veux bien être guidé.
Merci.
Last edited by jjm on 12 Aug 2016, 22:55, edited 1 time in total.
Seuls ceux qui sont assez fous pour penser qu'ils peuvent changer le monde y parviennent.
Henri Dunant, fondateur de la Croix Rouge
jjm
 
Posts: 132
Joined: 08 May 2013, 00:07

Re: Gérer les interfaces réseau

Postby sylvainsjc » 12 Aug 2016, 09:56

En fait je ne comprends pas trop ton problème et l'utilisation que tu en fais alors il faudrait un peu plus de précisions

- As-tu un intérêt particulier à avoir ces 2 sorties Ethernet connectées ? Sur mon portable, je suis connecté en WiFi et la carte Ethernet filaire qui est non connectée ne pose pas de soucis.
- En quoi c'est gênant pour les autres utilisateurs ? Que se passe t-il pour eux ?
- Comment désactives-tu ceci sur les autres distributions ?
:)
User avatar
sylvainsjc
 
Posts: 1273
Joined: 28 Jun 2012, 19:39

Re: Gérer les interfaces réseau

Postby jjm » 12 Aug 2016, 18:26


Re: Gérer les interfaces réseau

Unread postby sylvainsjc » 12 Aug 2016, 06:56
En fait je ne comprends pas trop ton problème et l'utilisation que tu en fais alors il faudrait un peu plus de précisions

- As-tu un intérêt particulier à avoir ces 2 sorties Ethernet connectées


Oui, à la mason il y a une windowsienne et un windowsien, qui utilisent "Réseau local", avec la carte intégrée. Je ne m'en sers pas pour la ménager, car sur cette carte mère acquise en 2008 :
--une sotie USB est HS
--le port PS2 pour la souris m'a laché en 2014-2015
De quoi être méfiant! Même si BIOSTAR opte pour la durabilité, cela fait deux incidents! Avant-hier, j'ai eu le problème de non-reconnaissance du clavier!

- En quoi c'est gênant pour les autres utilisateurs ? Que se passe t-il pour eux ?

Le windowsien dans sa chambre au 1er consomme beaucoup de bande passante, et le linuxien au RDC perturbe car nous sommes connectés via CPL.
Donc, si l'ordi du linuxien a deux interfaces réseau actives, c'est un peu comme si je connsommais les 2/3 de la B/P.
Si le windowsien est sur des jeux en ligne, la B/P s'effondre, donc forte perturbation pour les jeux, par exemple.
Donc :
--elle et lui : via-rhine sur cm Réseau local
--moi RTL 8139C dont j'ai au moins une unité de rechange! Et quand je windowse, Réseau local 2 sur pci.
C'est "presque simple".

- Comment désactives-tu ceci sur les autres distributions ?

Dans Mageia, c'est dans Configurer votre ordinateur.
Dans openSUSE, c'est dans Yast (Yet another setup tool), Système, Paramètres réseau.
Last edited by jjm on 12 Aug 2016, 23:02, edited 2 times in total.
Seuls ceux qui sont assez fous pour penser qu'ils peuvent changer le monde y parviennent.
Henri Dunant, fondateur de la Croix Rouge
jjm
 
Posts: 132
Joined: 08 May 2013, 00:07

Re: Gérer les interfaces réseau

Postby sylvainsjc » 12 Aug 2016, 21:25

Je comprends que même si tu désactives une carte réseau avec Network Manager, au redémarrage tu la retrouves actives et peut-être sous un autre nom ?
Je constate aussi ce comportement sur une ROSA MATE virtualisée...
A creuser
User avatar
sylvainsjc
 
Posts: 1273
Joined: 28 Jun 2012, 19:39

Re: Gérer les interfaces réseau

Postby HC_free » 12 Aug 2016, 22:02

Bonjour JJM

Pour pouvoir désactiver simplement le service network au démarrage, le module Drakxservices doit être installé.
Une fois le module installé, décochez tout simplement la case à cocher (au démarrage) du service network.
service_config.jpeg

Si cela est vraiment nécessaire pour vos besoins, dans un script qui sera executé lors du démarrage mettre la ligne suivante qui dépend de la carte réseau (eth0 dans notre cas) à désactiver.
Code: Select all
/sbin/ifconfig eth0 down


Pour créer un script de demarrage sous linux:
http://blog.nicolargo.com/2009/03/creation-dun-script-de-demarrage-sous-linux.html

ci-dessous, les différentes façons d'activer et désactiver une interface réseau.
Bringing interfaces up/down

Two methods can be used to bring interfaces up or down.
1. Using "ip"

Usage:

# ip link set dev <interface> up
# ip link set dev <interface> down

Example:

# ip link set dev eth0 up
# ip link set dev eth0 down

2. Using "ifconfig"

Usage:

# /sbin/ifconfig <interface> up
# /sbin/ifconfig <interface> down

Example:

# /sbin/ifconfig eth0 up
# /sbin/ifconfig eth0 down


Bon courage
HCD
KDE 4.14.13
ROSA Desktop Fresh R7
NVidia GeForce GT 240 1Go (NVIDIA Driver Version:340.96)
12Go de RAM
Kernel 4.2.22-nrj-desktop-3rosa-x86_64(SMP) on a AMD Phenom(tm) II X4 955 Processor 800.00 Mhz
User avatar
HC_free
 
Posts: 31
Joined: 16 Oct 2013, 02:31

Re: Gérer les interfaces réseau

Postby jjm » 12 Aug 2016, 23:13

Bonsoir,

Merci pour vos réponses.
Avant de lire le post de HCD, j'allais vérifier si "draknet" ou approchant est installé ou installable.
Je vais suivre la propositionn de HCD,
Merci pour le rappel des commandes root, notamment pour "ip" avec qui je suis très peu familier, l'ayant essayé une fois pour OpenMandriva (sortie 130).
Seuls ceux qui sont assez fous pour penser qu'ils peuvent changer le monde y parviennent.
Henri Dunant, fondateur de la Croix Rouge
jjm
 
Posts: 132
Joined: 08 May 2013, 00:07

Re: Gérer les interfaces réseau

Postby jjm » 13 Aug 2016, 16:51




Pour pouvoir désactiver simplement le service network au démarrage, le module Drakxservices doit être installé.
Une fois le module installé, décochez tout simplement la case à cocher (au démarrage) du service network.


Je n'ai pas trouvé ce paquet, mais dans MATE, Système, Administration, Services configuration, "network" est désactivé comme dans la copie d'écran.

D'autre part, dans la liste des paquets, drak-net (mode texte) et drakx-net) sont installés, mais dans un terminal root ces noms ne sont pas reconnus même en essayant différentes orthographes (j'ai un doute : féminin, masculin ou neutre?).
Cela m'aurait permis de voir la tronche de drakx-net.
La solution du script me semble actuellement la plus pertinente; mais malgré l'explication, je ne me sens pas à l'aise avec un script shell même très simple, notamment pour le ranger "au bon endroit".
Last edited by jjm on 14 Aug 2016, 16:32, edited 2 times in total.
Seuls ceux qui sont assez fous pour penser qu'ils peuvent changer le monde y parviennent.
Henri Dunant, fondateur de la Croix Rouge
jjm
 
Posts: 132
Joined: 08 May 2013, 00:07

Re: Gérer les interfaces réseau

Postby jjm » 13 Aug 2016, 17:13

Etonnant?
Dans MATE, pour démarrer "Services configuration" il faut être root.
Dans Plasma, pour le même module, pas de mot de passe!
Last edited by jjm on 14 Aug 2016, 16:25, edited 1 time in total.
Seuls ceux qui sont assez fous pour penser qu'ils peuvent changer le monde y parviennent.
Henri Dunant, fondateur de la Croix Rouge
jjm
 
Posts: 132
Joined: 08 May 2013, 00:07

Re: Gérer les interfaces réseau

Postby jjm » 13 Aug 2016, 17:44

Last edited by jjm on 13 Aug 2016, 23:43, edited 1 time in total.
Seuls ceux qui sont assez fous pour penser qu'ils peuvent changer le monde y parviennent.
Henri Dunant, fondateur de la Croix Rouge
jjm
 
Posts: 132
Joined: 08 May 2013, 00:07

Re: Gérer les interfaces réseau

Postby sylvainsjc » 13 Aug 2016, 22:06

Il y a juste clairement un bug avec systemd je pense.
De plus les interfaces ne se nomment plus eth0 et eth1 maintenant et ceci est valable sur la majorité des distributions avec systemd
Il faut faire un rapport de bug en anglais sur le bugzilla
je le ferai demain
User avatar
sylvainsjc
 
Posts: 1273
Joined: 28 Jun 2012, 19:39

Re: Gérer les interfaces réseau

Postby jjm » 14 Aug 2016, 00:06

Depuis openSUSE Tumbleweed (Rolling release)

Code: Select all
ifconfig -a
enp0s18   Link encap:Ethernet  HWaddr 00:E0:4D:41:66:D4 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

enp4s3    Link encap:Ethernet  HWaddr 00:08:54:51:FA:8E 
          inet adr:192.168.0.3  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::208:54ff:fe51:fa8e/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2801 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2104 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:3273236 (3.1 Mb)  TX bytes:203713 (198.9 Kb)


Capture d'écran de Yast Système Paramètres réseau :

http://pix.toile-libre.org/upload/origi ... 122351.png
Seuls ceux qui sont assez fous pour penser qu'ils peuvent changer le monde y parviennent.
Henri Dunant, fondateur de la Croix Rouge
jjm
 
Posts: 132
Joined: 08 May 2013, 00:07

Re: Gérer les interfaces réseau

Postby sylvainsjc » 14 Aug 2016, 08:58

Problème identique sur la dernière OpenMandriva...

Alors :
Tu ouvres la gestion du réseau (/usr/bin/nm-connection-editor) et tu configures tes interfaces comme tu le souhaites (changer le nom, activer ou pas la connexion si disponible)
Ensuite, taper cette commande dans le terminal :
Code: Select all
sudo systemctl disable systemd-networkd

Redémarrer et contrôler si les interfaces restent correctement dans l'état souhaité

Chez moi c'est Ok :
Sélection_026.jpg
User avatar
sylvainsjc
 
Posts: 1273
Joined: 28 Jun 2012, 19:39

Re: Gérer les interfaces réseau

Postby jjm » 14 Aug 2016, 16:02

D'abord, merci beaucoup pour le temps que tu as consacré à ce problème.

Dans Plasama, j'ai configuré les interfaces selon mes souhaits. Après redémarrage dans Plasma :

Code: Select all
Mot de passe :
jjm-P4M89-M7B jjm # ifconfig -a
enp0s18: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 00:e0:4d:41:66:d4  txqueuelen 1000  (Ethernet)
        RX packets 44  bytes 4907 (4.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp4s3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.3  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::99d:b34:b5b8:61dc  prefixlen 64  scopeid 0x20<link>
        ether 00:08:54:51:fa:8e  txqueuelen 1000  (Ethernet)
        RX packets 23  bytes 2814 (2.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 78  bytes 20642 (20.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


Donc, c'est "au poil". Je vais dans MATE où je n'ai pas trouvé NWN, sans redémarrer.

De retour, dans MATE (après déconnexion dans Plasma, n'ayant pas désiré "changer d'utilisateur" :

Code: Select all
jjm-P4M89-M7B jjm # ifconfig -a
enp0s18: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 00:e0:4d:41:66:d4  txqueuelen 1000  (Ethernet)
        RX packets 110  bytes 10194 (9.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1  bytes 42 (42.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp4s3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.3  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::99d:b34:b5b8:61dc  prefixlen 64  scopeid 0x20<link>
        ether 00:08:54:51:fa:8e  txqueuelen 1000  (Ethernet)
        RX packets 1613  bytes 1416495 (1.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1602  bytes 224780 (219.5 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


Le problème apparaît comme résolu.
J'attends un peu avant de mettre cette discussion en Résolu.

Pour OpenMandriva, la "release" est sortie et j'ai téléchargé l'ISO 64.
Comme toi, j'avais constaté ce même problème résdeau, notamment dans la RC1 qui a dû devenir RC2 avec plus de 500 màj.
Seuls ceux qui sont assez fous pour penser qu'ils peuvent changer le monde y parviennent.
Henri Dunant, fondateur de la Croix Rouge
jjm
 
Posts: 132
Joined: 08 May 2013, 00:07

Re: Gérer les interfaces réseau

Postby jjm » 15 Aug 2016, 01:14

Problème identique sur la dernière OpenMandriva...


Et sur la version finale!
La commande lancée pour ROSA n'a rien changé pour OpenMandriva.
Je visite les services.
Seuls ceux qui sont assez fous pour penser qu'ils peuvent changer le monde y parviennent.
Henri Dunant, fondateur de la Croix Rouge
jjm
 
Posts: 132
Joined: 08 May 2013, 00:07

Re: [Résolu] Gérer les interfaces réseau

Postby jjm » 08 Apr 2017, 18:04

[TROLL]
A propos d'interfaces, j'en ai remarqué une très jolie dans cette discussion!
download/file.php?avatar=5164_1399916458.jpg
[/TROLL]
Seuls ceux qui sont assez fous pour penser qu'ils peuvent changer le monde y parviennent.
Henri Dunant, fondateur de la Croix Rouge
jjm
 
Posts: 132
Joined: 08 May 2013, 00:07

Re: [Résolu] Gérer les interfaces réseau

Postby jjm » 11 Apr 2017, 09:33

sylvainjc,

Le bug subsiste : mais le problème est résolu en lançant la commande propossée.
Seuls ceux qui sont assez fous pour penser qu'ils peuvent changer le monde y parviennent.
Henri Dunant, fondateur de la Croix Rouge
jjm
 
Posts: 132
Joined: 08 May 2013, 00:07


Return to ROSA Desktop

Who is online

Users browsing this forum: No registered users and 1 guest