[РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

[РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Postby asupstudent » 22 Nov 2016, 20:00

Компания Mail.ru прекратила поддержку старых версий клиента к облаку и на сайте лежат новые версии для линукса. Раньше была возможность заргузить bin и работать, все работало отлично, сейчас только rpm.

Но при установке требует qt5-qtbase и qt5-qtx11extras. Имеется ли возможность обойти эту проблему, в репозитарии данных компонентов нет.
Возможно подключив какие то другие, но какие? или есть у кого bin новой версии клиента.

Спасибо
Last edited by asupstudent on 23 Nov 2016, 11:01, edited 1 time in total.
Не обижай слабого детеныша — он может оказаться сыном тигра.
User avatar
asupstudent
 
Posts: 122
Joined: 15 May 2012, 12:44
Location: г. Кулебаки, Нижегородская область

Re: Новая версия Облако Mail.ru для linux - не работает

Postby vlad » 22 Nov 2016, 21:30

Они не умеют rpm собирать.
vlad
 
Posts: 368
Joined: 27 Dec 2012, 03:44

Re: Новая версия Облако Mail.ru для linux - не работает

Postby ans » 22 Nov 2016, 22:10

asupstudent wrote:или есть у кого bin новой версии клиента.
Спасибо

А разархивировать rpm и достать оттуда bin?

Screenshot_20161123_001157.png
User avatar
ans
 
Posts: 1940
Joined: 11 Sep 2011, 07:42
Location: Ekaterinburg

Re: Новая версия Облако Mail.ru для linux - не работает

Postby Barmalei » 22 Nov 2016, 22:22

Он просит libQt5X11Extras.so.5
User avatar
Barmalei
 
Posts: 3808
Joined: 29 Dec 2014, 15:45

Re: Новая версия Облако Mail.ru для linux - не работает

Postby keleg » 23 Nov 2016, 02:41

urpmf libQt5X11Extras.so.5
lib64qt5x11extras5:/usr/lib64/libQt5X11Extras.so.5
keleg
 
Posts: 5008
Joined: 15 Sep 2011, 00:58

Re: Новая версия Облако Mail.ru для linux - не работает

Postby VictorR2007 » 23 Nov 2016, 04:36

asupstudent wrote:Но при установке требует qt5-qtbase и qt5-qtx11extras. Имеется ли возможность обойти эту проблему, в репозитарии данных компонентов нет.
Возможно подключив какие то другие, но какие? или есть у кого bin новой версии клиента.

Спасибо

Все пакеты есть в репах.
Только называются по другому.
Например lib64qt5x11extras5 или libqt5x11extras5.
Чтобы не искать нужные пакеты, можно установить какую-нибудь программу из реп на qt5,
чтобы подтянула нужные зависимости.
А потом удалить.
Например, plasma5-ark, а потом снова установить ark.
Во всём виноваты русские. Они всем вредят. Всегда. И ещё Путин. Ещё тот гусь. Тоже вредит. Всем. И всех захватывает. Ужас.:)
User avatar
VictorR2007
 
Posts: 4925
Joined: 12 Sep 2011, 12:00
Location: Северодвинск

Re: Новая версия Облако Mail.ru для linux - не работает

Postby asupstudent » 23 Nov 2016, 11:00

Спасибо за советы, проблему с установкой решил:

1 Скачал RPM пакет для 64 разрядной системы;
2 Извлек bin файл;
3 Удали ark, установил plasma5-ark + все зависимости;
4 запустил bin файл;
5 добавил в автозагрузку


Спасибо
Не обижай слабого детеныша — он может оказаться сыном тигра.
User avatar
asupstudent
 
Posts: 122
Joined: 15 May 2012, 12:44
Location: г. Кулебаки, Нижегородская область

Re: [РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Postby alexander-d3 » 11 Oct 2017, 18:49

Устанавливать можно командой
rpm -Uvh --nodeps --force mail-cloud15.rpm
User avatar
alexander-d3
 
Posts: 690
Joined: 31 Mar 2014, 21:48
Location: Москва

Re: [РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Postby tn243 » 13 Oct 2017, 09:18

xy MAILRU # rpm -Uvh --nodeps --force mail.ru-cloud-fedora-15.06-0112.x86_64.rpm
Подготовка... ########################################### [100%]
1:mail.ru-cloud ########################################### [100%]
Unexpected error.
Please follow instructions for manual installation on https://help.mail.ru/cloud_web/app/linux
error: %post(mail.ru-cloud-15.06-0112.x86_64) scriptlet failed, exit status 2

Однако неработает
tn243
 
Posts: 2
Joined: 13 Oct 2017, 09:11

Re: [РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Postby alexander-d3 » 13 Oct 2017, 09:33

Посмотри внимательней. Я ставлю на роса фреш R9x64. ставиться с ошибкой но устанавливается и работает. Да пробовал оба пакета. При установке импортирую публичный ключ.
User avatar
alexander-d3
 
Posts: 690
Joined: 31 Mar 2014, 21:48
Location: Москва

Re: [РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Postby tn243 » 13 Oct 2017, 09:42

да на r8 работает хоть и ош инсталл error: %post(mail.ru-cloud-15.06-0112.x86_64) scriptlet failed, exit status 2 !!
Хорошего настроения и удачного дня!
tn243
 
Posts: 2
Joined: 13 Oct 2017, 09:11

Re: [РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Postby alexander-d3 » 13 Oct 2017, 16:24

Два раза писал в теххподдержку с предложением собрать пакет для РОСЫ. Безуспешно, ноль реакции.
Пока видимо так придется устанавливать.
Attachments
1447747518_cloud-icon.png
User avatar
alexander-d3
 
Posts: 690
Joined: 31 Mar 2014, 21:48
Location: Москва


Return to Обсуждение ROSA Fresh R4 - R8 (платформа 2014.1)

Who is online

Users browsing this forum: Google [Bot] and 3 guests